< ESS User's Guide>

< ESS User's Guide:2024更新>

整合分析常用的英文應用軟體，有些是免費的(如MIX，RevMan，metafor)，有些需要付費(如CMA、WinBUGS、Stata)。筆者乃開發此中、英文整合分析軟體，以推廣整合分析研究。本軟體為利用Excel VBA所開發的增益集，筆者將它命名為Effect Size Synthesizer(以下簡稱ESS)。新版ESS除了修正與優質化既有程式(如森林圖中新增預測區間)之外，也新增效果值轉換副程式，可供各效果值間之轉換。

  • Main Functions and Features
  • ESS Design
  • ESS Interface
  • ESS Guides
  • ESS Outputs
  • Output Interpretaion
  • Trouble Shooting
  • Disclaimer


<ESS Design>

<基本架構與執行順序>

本軟體整合分析的執行，首先，需進行統計考驗力分析，以選用適切之研究樣本大小；接著，進行效果值之估計，出版偏差之評估與最後森林圖，漏斗圖等之繪製。著眼便利研究者操作與應用，ESS所設計的流程儘量簡化，讓電腦主動到事先設定的欄位讀取資料，以減少研究者準備統計分析所需資料及資料應放在哪一欄位的困擾。接著，研究者只要在ESS點選的統計分析選單，依序執行即可。換言之，累人的資料準備及統計分析過程，例如選擇哪些正確的變項、正確資料欄位的設定、統計量的計算與統計圖的製作，ESS將全部替您代勞。

ESS整合性分析軟體設計的基本架構及統計分析執行順序圖示如下:

本整合性分析軟體的設計，係依整合分析的前後分析步驟而構思：

一、進行統計考驗力分析，以決定適切之研究樣本大小，

二、進行效果值之估計，

三、出版偏差之評估與分析，

四、先漏斗圖，後森林圖之繪製。

因此，除了效果值轉換、Peto Odds效果值、次群體分析與整合回歸分析之外，其它模組之整合分析步驟，亦需依此順序逐一為之，才能獲得正確之分析結果；如果不按順序操作，除非具有該分析階段必備之數據，否則可能導致異常結果。


<ESS Inrerface>

<ESS 中英文介面規劃>

整合分析ESS的規劃步驟: 依序為樣本規劃、原始資料之建檔、效果值之估計、

出版偏差分析(含次群體分析&整合回歸分析)與

漏斗圖、森林圖製作等五大分析工作,以進行整體性之整合分析。

ESS具有中、 英文操作介面


<ESS Main Outputs>

1) Excel Spreadsheet

2) ESS Summary Tables

3) ESS Plots


<Main Functions & Features>

ESS(Effect Size Synthesizer)副程式，係具全方位功能的本土化整合分析軟體，主要特色及功能:

  • 利用大家熟悉的EXCEL表單格式，進行輸入資料，
  • 提供事先建置好的各種檔案格式，建檔快而準，
  • 呈現各階段分析過程的統計數據，研究者可以透過前後Excel表單，查看各階段的統計分析過程，
  • 提供四大類效果值的估計與整合分析，
  • 可進行事前研究樣本規劃，可評估出版偏差：Trim & Fill(提供刪補過程資料與結果)、整合回歸Trim & Fill、 Fail-Safe-N、Egger回歸截距法，
  • 多重異質性分析：次群體整合分析(處理類別變項)與整合回歸(處理多個預測變項)，
  • 提供經濟學常用的整合回歸分析: FAT-PET-MAR 模式 & PEESE 模式，
  • 可進行次群體間效果值差異的統計考驗，
  • 提供森林圖(新建預測區間)與漏斗圖分析。


<ESS Execution Order>

圖1中0~3的四個分析階段，顯示了整合分析ESS軟體設計的基本架構與ESS整合分析的流程，各階段間的分析環環相扣；其中，o階段係指整合分析前的準備工作：樣本規劃與資料的輸入，為第1階段資料分析做準備。第1階段旨在進行平均效果值的計算；根據第1階段資料分析的結果，進行第2階段的出版偏差與異質性之考驗；同樣的，根據第2階段的分析結果，進行第3階段的森林圖(新增預測區間)與漏斗圖的製作。ESS分階段進行整合分析，旨在讓使用者可以查看整合分析各階段的演算過程與邏輯，以利整合分析統計知能的教學。換言之，ESS同時重視分析結果與分析過程，因此，堪稱研究與教學兩相宜。

根據圖1的流程，整合分析的前導工作為樣本規劃與資料準備；其次，ESS的統計分析執行順序為:除了Peto Odds效果值之外，整合分析的效果值計算先於「Trim & Fill」分析，「Trim & Fill」分析先於漏斗圖或森林圖的製作。

圖1 整合分析軟體ESS的階段分析設計與資料分析順序

研究者在效果值的整合分析之後，就可進行執行「Trim & Fill」分析，此階段電腦程式會自動讀取相關數據，進行整合分析研究的刪補工作，並重估刪之前、刪之後與補之後的平均效果值，所有刪之後與補之後的過程分析數據，均會在EXCEL表單上呈現出來，以利研究者查看刪與補過程中的過程分析結果，也可便利「Trim & Fill」分析的教學。執行「Trim & Fill」之後，ESS會自動備齊各研究之效果值與標準誤，以進行漏斗圖或森林圖之工作。


<Study Sample Size Planning>

<Mean Difference的樣本規劃>


<Data Entry Format>

<ESS建檔格式>

運用ESS整合性分析軟體，在建立原始資料檔案格式時，需依各效果值類別而建立，

不允許有任何偏差，否則會有不正確的分析結果。

ESS內建三大類十一種效果值格式，以確保資料建檔之正確性與效率。

I、以平均數差異效果值(Mean Difference)為例，其內建檔案格式如下所示:

II、診斷性資料(Proportion)的三種輸入格式

<診斷性資料的輸入格式>

註: TP:診斷工具能診斷出真正有病的人數(true positive)

FP:診斷工具誤診斷為有病的人數(false positive)

FN:診斷工具誤診斷為無病的人數(false negative)

TN:診斷工具能診斷出真正無病的人數(true negative)


<ESS Windows>

<ESS Input Box>

Input Box


<Diagnostic data entry>

ESS 提供三種Diagnostic data的比率整合分析:

正確診斷率

整體流行率

特殊診斷率


<Sensitivity>

<正確診斷率>

註: TP:診斷工具能診斷出真正有病的人數(true positive)

FP:診斷工具誤診斷為有病的人數(false positive)

FN:診斷工具誤診斷為無病的人數(false negative)

TN:診斷工具能診斷出真正無病的人數(true negative)


<Specificity>

<特殊診斷率>

註: TP:診斷工具能診斷出真正有病的人數(true positive)

FP:診斷工具誤診斷為有病的人數(false positive)

FN:診斷工具誤診斷為無病的人數(false negative)

TN:診斷工具能診斷出真正無病的人數(true negative)


<Overall prevalence>

<整體流行率>

註: TP:診斷工具能診斷出真正有病的人數(true positive)

FP:診斷工具誤診斷為有病的人數(false positive)

FN:診斷工具誤診斷為無病的人數(false negative)

TN:診斷工具能診斷出真正無病的人數(true negative)


Effect Size Conversion

<Effecvt Size Conversion>


<Effect Size Calculation>

計算四大類效果值與ESS副程式


<Sub-Group Analysis>

次群體分析介面


<Meta-Regression>

整合回歸分析界面


<Fat-Pet-Mra Model>

<FAT-PET-Mra模式>

整合回歸分析法，本質上係WLS-MRA模式，其回歸係數估計值可以透過OLS估計法求得。本模式的最大優點，

乃是可以排除出版偏差與其他變異源之效應，估計該研究的淨效果值。本法係Egger回歸截距法的延伸，

增加了詮釋效果值變異量的重要調節變項；這些新加入的調節變項可為類別變項，也可為連續變項。

FAT-PET-Mra的操作介面:


<Fail-Safe-N>


<Egger's Regression Intercept>

<Egger回歸截距法>


<Trim & Fill>

<Trim & Fill表單>


<Meta-regression-Trim-Fill>

ESS整合回歸Trim & Fill操作介面

ESS整合回歸Trim & Fill實例


<Forest Plot>

<ESS Forest Plot>

森林圖製作&分析

含固定效果模式、隨機效果模式的信賴區間&

隨機效果模式的預測區間。

ESS輸出結果:固定效果模式

ESS輸出結果:隨機效果模式

一、信賴區間

二、預測區間


<Funnel Plot>

<ESS Funnel Plot>

漏斗圖分析輸出結果


<ESS Summary Output>

ESS 輸出報表


<Excel Spredsheet output>

<Excel Spreadsheet Output>

Excel Ouput


<Output Interpretation>

<ESS Output Interpretation>

ESS報表的解釋,請參閱筆者專書(傳統整合分析理論與實務)第八章


<Message Box>

<ESS Message Box>


<Author>

李茂能

美國喬治亞大學哲學博士

嘉義大學教育學系暨研究所名譽教授


<Disclaimer>

<免責聲明>

Many attempts have been made to make sure that ESS is free from Errors.

If any bugs are found, I would eliminate them as soon as possible.

This Excel Macro is offered to the readers or researchers as free of charge and as it is

and

I accept no responsibility for any unexpected consequences that might result from its use.


<How to use ESS>

<使用者操作ESS須知>

ESS使用者必須嚴守前述的操作順序，依序執行資料分析，就能確保獲得正確的統計分析與製圖結果。不過有一例外，Peto Odds的整合分析，因為其計算過程需使用原始資料，而無法與其它效果值使用共同的副程式，必須另立一副程式，ESS將同時進行Peto Odds平均效果值的計算與Trim & Fill分析，之後再進行漏斗圖或森林圖之製作。

確保前後不同筆或不同統計分析間參數設定不會錯亂傳遞，請在每一次結束整合分析之製圖後，建議關閉該筆資料的Excel表單，再進行其它筆資料的整合分析，以確保資料分析能正常運作。

欲知更詳細內容，請參閱筆者五南出版之專書:"傳統整合分析理論與實務:ESS & EXCEL"第七章!

初學者必備須知與技巧:

  • 原始資料檔案的輸入格式
  • ESS執行順序
  • 研究樣本數規劃
  • 效果值的計算
  • 出版偏差的檢測
  • 次群體分析
  • 整合回歸分析
  • 漏斗圖分析
  • 森林圖分析


<Publication Bias Checkup>

ESS出版偏差分析，主要包含以下幾個技術:

  • Trim & fill
  • Fail_Safe_N
  • Eager's regression-intercept
  • Meta-regression-trim-fill


<Plot Checkup>

<ESS Plot Checkup>

  • Forest Plot
  • Funnel Plot


<ESS trouble shooting>

ESS的製圖功能可能因前次參數傳遞仍未解除，而造成其後無法正確製圖或出現錯亂的森林圖形。

因此，重新製圖前建議使用者最好先關閉Excel，愛再開啟Excel，依序執行統計分析(效果值的計算 & Trim & Fill分析)，

再執行ESS的統計製圖。


<Subgroup Comparisons>